summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuca Bacci <luca.bacci982@gmail.com>2022-10-14 16:28:11 +0200
committerLuca Bacci <luca.bacci982@gmail.com>2022-10-28 12:44:45 +0200
commitc75220fe089f649a7179520b2969da43d8e0e8b3 (patch)
tree19c5961cd97dca07a4f8c0a4d3e7ee876bafa99a /meson.build
parent0a111ad1fabdf75837002294bdfc33f18bdb4ec1 (diff)
downloadcairo-c75220fe089f649a7179520b2969da43d8e0e8b3.tar.gz
Remove explicit dependency on libssp
It's not needed anymore. Linking explicitly with libssp was required for toolchains where the target libc doesn't implement stack smashing protection routines on its own, and instead delegates to the generic implementations provided by libssp. Notably, this was the case of mingw-w64 toolchains. After discussion upstream with Meson developers [1], the stance taken is that Meson users (and Meson itself) shall have no knowledge of the libc internals and whether libssp is required. instead, libc's should declare a dependency on the generic libssp on their own by means of .spec files [2]. Following the discussion in Meson Github, the issue was then fixed in mingw-w64 upstream [3]. References: * https://github.com/mesonbuild/meson/issues/10673 * https://gcc.gnu.org/onlinedocs/gcc/Spec-Files.html * https://github.com/msys2/MINGW-packages/issues/13401
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 970f49a52..180cfacf5 100644
--- a/meson.build
+++ b/meson.build
@@ -69,7 +69,7 @@ if cc.get_id() != 'msvc'
]
if get_option('optimization') in ['1', '2', '3']
- cflags += ['-Wp,-D_FORTIFY_SOURCE=2', '-Wl,-lssp']
+ cflags += '-Wp,-D_FORTIFY_SOURCE=2'
endif
supported_cflags = cc.get_supported_arguments(cflags)