summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2023-01-08 13:33:14 +1030
committerAdrian Johnson <ajohnson@redneon.com>2023-01-08 15:15:13 +1030
commitdd8f55100a260d34732dbddff94c3d20071228a7 (patch)
treecf60772cb5a33519c7f2993017bdf2a9930e6616 /meson.build
parent89d004432b218d2641439c01fd93deda390a25b1 (diff)
downloadcairo-dd8f55100a260d34732dbddff94c3d20071228a7.tar.gz
Require -DDEBUG_ENABLE_COLR_V1 to enable the COLR v1 renderer
Once there is a FreeType release where the COLR v1 API is no longer marked experimental, we can change this to a version check.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 75bbf37b1..4dedeadee 100644
--- a/meson.build
+++ b/meson.build
@@ -320,7 +320,6 @@ if freetype_dep.found()
}]
ft_check_funcs = [
- 'FT_Get_Color_Glyph_Paint',
'FT_Get_X11_Font_Format',
'FT_GlyphSlot_Embolden',
'FT_GlyphSlot_Oblique',
@@ -346,6 +345,11 @@ if freetype_dep.found()
conf.set('CAIRO_CAN_TEST_TTX_FONT', 1)
endif
endif
+ # When FT COLRv1 API is no longer experimental we can change this to a
+ # version check for the stable COLRv1 API.
+ if cc.get_define('DEBUG_ENABLE_COLR_V1') != ''
+ conf.set('HAVE_FT_COLR_V1', 1)
+ endif
check_funcs += ft_check_funcs
deps += [freetype_dep]
endif