summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-17 23:44:33 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-02-25 01:39:29 +0000
commit81ecff3800e6d71dadbe42d2f29976d9208784a1 (patch)
treeb5edc11b3f70a35905718d0ac7a34204956f7148 /src/Makefile.am
parent64ece6d545df015377a1f289829eeea20f5ae019 (diff)
downloadcairo-81ecff3800e6d71dadbe42d2f29976d9208784a1.tar.gz
Remove BeOS support
Nobody cares about BeOS in 2022, and it cannot be built with Meson anyway. Removing the BeOS backend also allows us to drop the dependency on a C++ compiler and simplify the Autotools build considerably by removing all the extra CXX targets.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 2 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 23ba1861d..c03ef71a8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,32 +22,14 @@ cairoinclude_HEADERS = $(enabled_cairo_headers)
lib_LTLIBRARIES = libcairo.la
-if BUILD_CXX
-cairo_cxx_lib = libcairo_cxx.la
-else
-cairo_cxx_lib =
-endif
-
-noinst_LTLIBRARIES = $(cairo_cxx_lib)
-libcairo_cxx_la_SOURCES = \
- $(enabled_cairo_headers) \
- $(enabled_cairo_private) \
- $(enabled_cairo_cxx_sources) \
- $(NULL)
-libcairo_cxx_la_LDFLAGS = $(AM_LDFLAGS) $(export_symbols)
-libcairo_cxx_la_LIBADD = $(CAIRO_LIBS)
-libcairo_cxx_la_DEPENDENCIES = $(cairo_def_dependency)
-
-
libcairo_la_SOURCES = \
$(enabled_cairo_headers) \
$(enabled_cairo_private) \
$(enabled_cairo_sources) \
$(NULL)
libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
-libcairo_la_LIBADD = $(CAIRO_LIBS) \
- $(cairo_cxx_lib)
-libcairo_la_DEPENDENCIES = $(cairo_def_dependency) $(cairo_cxx_lib)
+libcairo_la_LIBADD = $(CAIRO_LIBS)
+libcairo_la_DEPENDENCIES = $(cairo_def_dependency)
# Special headers
nodist_cairoinclude_HEADERS = cairo-features.h