summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2007-09-21 10:45:55 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2007-09-25 16:29:54 +0100
commit8b6c871c9084739460f1320cd36560a09477a83e (patch)
treed6f0259aaff65a247d97edb8bb557d5febdc2b5e /src/Makefile.am
parent42de1a0a7f5cc10c2bad98ef69da302ed2a1ca84 (diff)
downloadcairo-8b6c871c9084739460f1320cd36560a09477a83e.tar.gz
[cairo-atomic] Introduce atomic ops.
Test for the availability of the Intel __sync_* atomic primitives and use them to define a few operations useful for reference counting - providing a generic interface that may be targeted at more architectures in the future. If no atomic primitives are available, use a mutex based variant. If the contention on that mutex is too high, we can consider using an array of mutexes using the address of the atomic variable as the hash.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 85964e30c..2e6d2c60e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -172,6 +172,8 @@ libcairo_la_base_sources = \
cairo-arc.c \
cairo-arc-private.h \
cairo-array.c \
+ cairo-atomic.c \
+ cairo-atomic-private.h \
cairo-base85-stream.c \
cairo-bentley-ottmann.c \
cairo-cache.c \