summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2008-08-14 16:30:54 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2008-08-17 11:39:56 +0100
commitdb7e3cb85467496686289d1a666b4ca274524fdd (patch)
tree9638af12e61170a2506299b7376fbd9c8781c801 /src/Makefile.am
parent67326b728bca24dc02df7f144b9471636d5e1d4c (diff)
downloadcairo-db7e3cb85467496686289d1a666b4ca274524fdd.tar.gz
[Makefile.am] Delete intermediates
Clean up after calling 'gcc -save-temps'.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 24694fc50..7869877f1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -364,6 +364,10 @@ TESTS = check-def.sh check-plt.sh check-headers.sh check-cairoint.sh check-doc-s
EXTRA_DIST += $(TESTS) check-has-hidden-symbols.c
DISTCLEANFILES += check-has-hidden-symbols.i
+# Delete intermediate files as well
+clean-local:
+ -${FIND} . -name '*.[is]' -print | ${XARGS} ${RM}
+
# The pre-processed result is used by check-{def,plt}.sh to determine whether
# cairo has been compiled with symbol hiding.
.c.i: $(cairoinclude_HEADERS) $(nodist_cairoinclude_HEADERS) cairoint.h $(top_builddir)/config.h