summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorUli Schlachter <psychon@znc.in>2021-06-17 14:25:16 +0000
committerUli Schlachter <psychon@znc.in>2021-06-17 14:25:16 +0000
commit43a48fb6a51066665e2ed5736eb8874c8f696693 (patch)
tree0e89eea2948aa645176b6285d57f304fbca62681 /src/meson.build
parent07d60121858e91ddba1aa7eda5f6474977b8c940 (diff)
parent339671c7872335a5ce748a635a314cbe375e303e (diff)
downloadcairo-43a48fb6a51066665e2ed5736eb8874c8f696693.tar.gz
Merge branch 'more-meson' into 'master'
Add more of the auto-foo build to meson See merge request cairo/cairo!183
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 58a798404..bfe7c9018 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -320,3 +320,30 @@ pkgmod.generate(libcairo,
meson.override_dependency('cairo', libcairo_dep)
install_headers(cairo_headers, subdir: 'cairo')
+
+shell = find_program('sh', required: false)
+if shell.found()
+ test_scripts = [
+ # This script calls back into make to generate cairo.def
+ # TODO: Make this work, somehow
+ #'check-def.sh',
+ 'check-doc-syntax.sh',
+ 'check-headers.sh',
+ 'check-preprocessor-syntax.sh',
+ ]
+
+ foreach test_script: test_scripts
+ test(test_script, shell,
+ args: [test_script],
+ workdir: meson.current_source_dir())
+ endforeach
+
+ env = environment()
+ env.set('CAIRO_HAS_HIDDEN_SYMBOLS', '1')
+
+ test('check-plt.sh', shell,
+ args: ['check-plt.sh', libcairo ],
+ env: env,
+ workdir: meson.current_source_dir())
+
+endif