summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2022-01-21 11:58:09 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2022-01-21 11:59:36 +0530
commit57498b301c10fa24b4882c1b2d5785eff3f25c1a (patch)
treedeb2ede812d8468374ccc793bdbfe44d503bccf6 /src/meson.build
parenta6b2a39f36aa2ac9a1d8afec16d042694839f48f (diff)
downloadcairo-57498b301c10fa24b4882c1b2d5785eff3f25c1a.tar.gz
meson: Fix build when PDF backend is disabled
Symbols from cairo-tag-stack.c are used by cairo-tag-attributes.c, so this should be in the same list of sources as that. Fixes this build error: ``` /usr/bin/ld: src/libcairo.so.2.11705.0.p/cairo-tag-attributes.c.o: in function `parse_array': /path/to/cairo/_build/../src/cairo-tag-attributes.c:347: undefined reference to `_cairo_tag_error' /usr/bin/ld: src/libcairo.so.2.11705.0.p/cairo-tag-attributes.c.o: in function `parse_name': /path/to/cairo/cairo/_build/../src/cairo-tag-attributes.c:359: undefined reference to `_cairo_tag_error' /usr/bin/ld: src/libcairo.so.2.11705.0.p/cairo-tag-attributes.c.o: in function `parse_attributes': /path/to/cairo/cairo/_build/../src/cairo-tag-attributes.c:410: undefined reference to `_cairo_tag_error' /usr/bin/ld: /path/to/cairo/cairo/_build/../src/cairo-tag-attributes.c:431: undefined reference to `_cairo_tag_error' /usr/bin/ld: /path/to/cairo/cairo/_build/../src/cairo-tag-attributes.c:441: undefined reference to `_cairo_tag_error' /usr/bin/ld: src/libcairo.so.2.11705.0.p/cairo-tag-attributes.c.o:/path/to/cairo/cairo/_build/../src/cairo-tag-attributes.c:455: more undefined references to `_cairo_tag_error' follow /usr/bin/ld: src/libcairo.so.2.11705.0: hidden symbol `_cairo_tag_error' isn't defined ```
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 99b3a84a6..d0a8853f6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -114,6 +114,7 @@ cairo_sources = [
'cairo-pdf-operators.c',
'cairo-pdf-shading.c',
'cairo-tag-attributes.c',
+ 'cairo-tag-stack.c',
'cairo-deflate-stream.c',
]
@@ -234,7 +235,6 @@ cairo_feature_sources = {
'cairo-pdf': [
'cairo-pdf-surface.c',
'cairo-pdf-interchange.c',
- 'cairo-tag-stack.c',
],
'cairo-svg': [
'cairo-svg-surface.c',