summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2022-06-14 22:01:04 +0930
committerAdrian Johnson <ajohnson@redneon.com>2022-12-28 13:22:00 +1030
commit1bd5751324866a2bfbb084fcb7d5462d983a878e (patch)
treec331a335353089f1fd0b22cb0128697072513a0a /test/meson.build
parent31700fed4f4eb2efb1b445c27b4016ea85bb14f3 (diff)
downloadcairo-1bd5751324866a2bfbb084fcb7d5462d983a878e.tar.gz
FT SVG color font test
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 47d590690..7d6d6e11b 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -425,6 +425,10 @@ test_ft_font_sources = [
'ft-text-antialias-none.c',
]
+test_ft_svg_font_sources = [
+ 'ft-svg-color-font.c',
+]
+
test_gl_sources = [
'gl-device-release.c',
'gl-oversized-surface.c',
@@ -525,6 +529,9 @@ endif
if feature_conf.get('CAIRO_HAS_FT_FONT', 0) == 1 and feature_conf.get('CAIRO_HAS_FC_FONT', 0) == 1
test_sources += test_ft_font_sources
+ if conf.get('HAVE_FT_SVG_DOCUMENT', 0) == 1
+ test_sources += test_ft_svg_font_sources
+ endif
endif
if feature_conf.get('CAIRO_HAS_QUARTZ_SURFACE', 0) == 1