summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorUli Schlachter <psychon@znc.in>2021-05-22 08:16:47 +0200
committerUli Schlachter <psychon@znc.in>2021-05-22 08:16:47 +0200
commit1e34651420fa77edb09045ee0ff33432c4e73d70 (patch)
tree656c3d2de9cff543447b0f4112cc39a309b9a323 /test/meson.build
parent1981fb6dfb51f44feb68590f51309520185e0780 (diff)
downloadcairo-1e34651420fa77edb09045ee0ff33432c4e73d70.tar.gz
Fix meson build without zlib
Trying to build with meson with -Dzlib=disabled failed with the following error message: cairo/test/meson.build:599:2: ERROR: Unknown variable "libcairoscript_dep". This commit fixes that problem by adding a not-found dependency if cairo-script is not built. Additionally, follow-up problems are fixed: - any2ppm.c still tried to include cairo-script-interpreter.h, which was not found - Building cairo-test-trace was attempted, but that also failed because of missing script support. Fixes: https://gitlab.freedesktop.org/cairo/cairo/-/issues/475 Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 3039cf6da..fed35c310 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -602,7 +602,7 @@ if build_any2ppm
test_depends += [any2ppm_exe]
endif
-if have_shm
+if have_shm and conf.get('CAIRO_HAS_INTERPRETER', 0) == 1
cairo_test_trace_exe = executable('cairo-test-trace', cairo_test_trace_sources,
include_directories: [incbase],
c_args: pthread_c_args,