summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2022-05-18 10:37:37 +0930
committerAdrian Johnson <ajohnson@redneon.com>2022-05-19 06:44:58 +0930
commit29acc5584915be294b2d7ed926d9ac48346474e3 (patch)
treec9d037cf671c58de5eb048233c645f7c42c59e35 /test/meson.build
parente562ff757bb7d88b708e07a9759c046413c52f94 (diff)
downloadcairo-29acc5584915be294b2d7ed926d9ac48346474e3.tar.gz
Make it easier for cairo-test-suite to find the source dir
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index be05d30ec..bc1547494 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -634,6 +634,13 @@ foreach file : html_files
configure_file(input: file, output : file, copy: true)
endforeach
+if build_machine.system() != 'windows'
+ run_command('ln', '-sf',
+ meson.current_source_dir(),
+ join_paths(meson.current_build_dir(), 'srcdir'),
+ check: true)
+endif
+
env = environment()
env.set('srcdir', meson.current_source_dir())