summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorManuel Stoeckl <code@mstoeckl.com>2021-08-21 09:26:21 -0400
committerManuel Stoeckl <code@mstoeckl.com>2023-01-11 06:39:23 -0500
commit39f8be09f83b2c904c513fd0a7f28086cdc47689 (patch)
treeca11fa450c5fa1a566b24dd73ad59a7b6251bcd8 /test/meson.build
parentb0a5c3a11fdcca4460b7c4cd5dc711e8b1d16537 (diff)
downloadcairo-39f8be09f83b2c904c513fd0a7f28086cdc47689.tar.gz
Add test for loading 16 bit PNG images
The base image has 16 bits per channel, with colors that do not have an exact corresponding 8 bit representation. The reference image uses 8bpc, like the rgb24/argb32 formatted images which the test outputs.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 28047cb04..e670a3937 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -96,6 +96,7 @@ test_sources = [
'create-for-stream.c',
'create-from-broken-png-stream.c',
'create-from-png.c',
+ 'create-from-png-16bit.c',
'create-from-png-stream.c',
'culled-glyphs.c',
'curve-to-as-line-to.c',