summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-07-14 18:11:38 +0100
committerSimon McVittie <smcv@debian.org>2022-07-14 18:12:50 +0100
commit947f40f511efd8d36e78c1a76c57daa8f6886de0 (patch)
tree6391d918f851cf34d2ff2f90171981d8533524f1 /test/meson.build
parentda5450e7292091acd9dabc1600fb651467261a3b (diff)
downloadcairo-947f40f511efd8d36e78c1a76c57daa8f6886de0.tar.gz
meson: Split tests up into test suites
This allows things like `meson test --no-suite=slow` to run subsets of the complete set of tests. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index bc1547494..47d590690 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -648,5 +648,6 @@ env.set('srcdir', meson.current_source_dir())
test('cairo', exe,
timeout: 60 * 60,
env: env,
+ suite: ['cairo-test-suite', 'slow'],
workdir: meson.current_build_dir(),
depends: test_depends)