summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2023-02-19 21:10:58 +1030
committerAdrian Johnson <ajohnson@redneon.com>2023-04-18 18:27:12 +0930
commitb53b48116e610d61cdf630c24a11b59a18345e16 (patch)
tree3bc8f3410e795ce81c1408b9d7f3a217033d29ba /test/meson.build
parente7ed40a71dac04cb4c608b409b04577d01f08454 (diff)
downloadcairo-b53b48116e610d61cdf630c24a11b59a18345e16.tar.gz
Make cairo_tag_begin/end work correctly in groups
Fixes #508
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 548e25b4d..1d76d5daa 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -452,6 +452,10 @@ test_pdf_sources = [
'pdf-tagged-text.c',
]
+test_pdf_structure_sources = [
+ 'pdf-structure.c',
+]
+
test_ps_sources = [
'ps-eps.c',
'ps-features.c',
@@ -555,6 +559,9 @@ endif
if feature_conf.get('CAIRO_HAS_PDF_SURFACE', 0) == 1
test_sources += test_pdf_sources
+ if host_machine.system() != 'windows'
+ test_sources += test_pdf_structure_sources
+ endif
has_multipage_surfaces = true
add_fallback_resolution = true
build_any2ppm = true