summaryrefslogtreecommitdiff
path: root/util/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2023-02-04 11:36:25 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2023-02-04 11:36:25 +0100
commit2bef8669bc992f06300464d72d8c4ea4bef8a479 (patch)
tree41ae2d6de491dac66f431a0d3815e68a6a3c0fd5 /util/meson.build
parent338eca43428d1956216362eeb8e1715bac99d876 (diff)
downloadcairo-2bef8669bc992f06300464d72d8c4ea4bef8a479.tar.gz
Remove XML surface
According to the Debian code search tool, nothing uses it as part of the Cairo public API, and it has been disabled for a long time with nobody complaining about it.
Diffstat (limited to 'util/meson.build')
-rw-r--r--util/meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/util/meson.build b/util/meson.build
index 5cc209cc9..3c3bf26c2 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -42,14 +42,6 @@ if gtk_dep.found()
]
endif
-if feature_conf.get('CAIRO_HAS_XML_SURFACE', 0) == 1
- expat_dep = dependency('expat', fallback: ['expat', 'expat_dep'])
- cairo_utils += [
- ['trace-to-xml.c', {'deps': [expat_dep]}],
- ['xml-to-trace.c', {'deps': [expat_dep]}],
- ]
-endif
-
foreach util : cairo_utils
exe_name = util[0].split('.')[0]
util_deps = util.get(1, {}).get('deps', [])