summaryrefslogtreecommitdiff
path: root/util/meson.build
diff options
context:
space:
mode:
authorGeorge Matsumura <gmmatsumura01@bvsd.org>2020-08-30 18:29:05 -0600
committerUli Schlachter <psychon@znc.in>2020-09-02 10:29:04 +0000
commitf2cb9ba49a222c6e17603f5fb8cbb02f82d0bbf7 (patch)
treee0aa9eeb969ab733bd424a04d90f13c9933aa57c /util/meson.build
parentb87e53dc1cc4dd33fa391f3ee8db02394b44a742 (diff)
downloadcairo-f2cb9ba49a222c6e17603f5fb8cbb02f82d0bbf7.tar.gz
meson: Fix musl build
This constitutes few fixes that are necessary to compile correctly and reduce errors when using musl libc. Signed-off-by: George Matsumura <gmmatsumura01@bvsd.org>
Diffstat (limited to 'util/meson.build')
-rw-r--r--util/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/util/meson.build b/util/meson.build
index 3f16d7c78..6982ad758 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -58,8 +58,7 @@ foreach util : cairo_utils
)
endforeach
-# This is useless and doesn't build on Windows
-if host_machine.system() != 'windows'
+if cc.has_header_symbol('malloc.h', '__malloc_hook')
libmallocstats = library('malloc-stats', 'malloc-stats.c')
endif