summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 831527c43..02f74856c 100644
--- a/meson.build
+++ b/meson.build
@@ -302,6 +302,8 @@ if fontconfig_dep.found()
}]
endif
+ttx = find_program('ttx', required: false)
+
freetype_dep = dependency('freetype2',
required: get_option('freetype'),
version: freetype_required_version,
@@ -339,6 +341,9 @@ if freetype_dep.found()
endif
if cc.has_type('FT_SVG_Document', dependencies: freetype_dep, prefix: '#include <freetype/otsvg.h>')
conf.set('HAVE_FT_SVG_DOCUMENT', 1)
+ if ttx.found()
+ conf.set('CAIRO_CAN_TEST_TTX_FONT', 1)
+ endif
endif
check_funcs += ft_check_funcs
deps += [freetype_dep]