summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@unixuser.org>2012-10-31 15:37:30 +0900
committerDaiki Ueno <ueno@unixuser.org>2012-12-30 14:25:41 +0900
commit4e2469f73fa1f6c0112275b1eadba104f867dd0c (patch)
tree34ded2400e5d121b6d3282a450b1afdd2b21704f /Makefile.am
parent9c6e23a90e40799f3530535fc55b5cb740b6e649 (diff)
downloadcaribou-4e2469f73fa1f6c0112275b1eadba104f867dd0c.tar.gz
build: use git.mk
Use git.mk to generate .gitignore files upon building. Also remove *.[ch] from CLEANFILES since it makes little sense with automake Vala support. https://bugzilla.gnome.org/show_bug.cgi?id=687315
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a507570..3cd2140 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,3 +9,19 @@ endif
DISTCHECK_CONFIGURE_FLAGS = \
--enable-docs \
$(NULL)
+
+GITIGNOREFILES = \
+ INSTALL \
+ aclocal.m4 \
+ config.guess \
+ config.sub \
+ depcomp \
+ git.mk \
+ install-sh \
+ ltmain.sh \
+ m4 \
+ missing \
+ mkinstalldirs \
+ py-compile
+
+-include $(top_srcdir)/git.mk