summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@unixuser.org>2012-10-31 12:15:26 +0900
committerDaiki Ueno <ueno@unixuser.org>2012-12-30 14:16:07 +0900
commit89b918dfbb11f8ccc3162eb84097c39baccac9cc (patch)
tree2e4ff4d48291bab92568b1d3876ab5daf956da0f /Makefile.am
parent73e45d3d4e848168b2c78dc8953167f222dfc768 (diff)
downloadcaribou-89b918dfbb11f8ccc3162eb84097c39baccac9cc.tar.gz
Add documentation support
Add Valadoc documentation support in the build system. The template is borrowed from Folks. https://bugzilla.gnome.org/show_bug.cgi?id=687244
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6196fc2..a507570 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,11 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = caribou bin data po libcaribou modules tools
+
+if HAVE_VALADOC
+SUBDIRS += docs
+endif
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-docs \
+ $(NULL)