summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEitan Isaacson <eitan@monotonous.org>2010-05-03 23:12:51 -0700
committerEitan Isaacson <eitan@monotonous.org>2010-05-03 23:19:35 -0700
commitee151fca17e12d31fb2baf75c6441b1e5e219f8d (patch)
tree7e07258ff7fa24559f6959f13e68027cee47cf22 /configure.ac
parentfc4d61a700141eefdbd5e0401806bfa371a0a4a8 (diff)
downloadcaribou-ee151fca17e12d31fb2baf75c6441b1e5e219f8d.tar.gz
Added automake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..1b4639b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_INIT(caribou, 0.1.0, eitan@monotonous.org)
+AM_INIT_AUTOMAKE
+AM_MAINTAINER_MODE
+GNOME_DOC_INIT
+
+dnl == check for python ==
+AM_PATH_PYTHON(2.4)
+
+dnl == i18n ==
+#GETTEXT_PACKAGE=caribou
+#AC_SUBST(GETTEXT_PACKAGE)
+#AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [The gettext package])
+#AM_GLIB_GNU_GETTEXT
+
+dnl == intltool check ==
+#IT_PROG_INTLTOOL([0.35.0])
+
+dnl == generate makefiles ==
+AC_OUTPUT([
+Makefile
+caribou/Makefile
+bin/Makefile
+bin/caribou
+])