summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorNohemi Fernandez <nf68@cornell.edu>2011-07-28 11:35:55 -0500
committerEitan Isaacson <eitan@monotonous.org>2011-08-12 09:19:40 +0200
commit35fbd7d84509a6f4c7df8274450733fd0afd9044 (patch)
tree72937acb432d64084a273ed58a7f537549d38c72 /modules/Makefile.am
parent875abe21f807f01121bae506745c1a9432b39227 (diff)
downloadcaribou-35fbd7d84509a6f4c7df8274450733fd0afd9044.tar.gz
Add Caribou to GTK_MODULES
The Caribou IM module would override any other modules the user is utilizing; by adding it to the GTK_MODULES the user can decide whether or not to enable the module (enabled automatically for onscreen keyboard) and will avoid override. There is also no dependency for the abstract class GtkIMContextSimple.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
new file mode 100644
index 0000000..47ecbb7
--- /dev/null
+++ b/modules/Makefile.am
@@ -0,0 +1,9 @@
+SUBDIRS =
+
+if ENABLE_GTK3_MODULES
+SUBDIRS += gtk3
+endif
+
+if ENABLE_GTK2_MODULES
+SUBDIRS += gtk2
+endif