summaryrefslogtreecommitdiff
path: root/unittest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittest/CMakeLists.txt')
-rw-r--r--unittest/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/unittest/CMakeLists.txt b/unittest/CMakeLists.txt
index 2a3edf0d..062961f0 100644
--- a/unittest/CMakeLists.txt
+++ b/unittest/CMakeLists.txt
@@ -49,7 +49,7 @@ list(APPEND source_files ${headers})
add_executable(unittest ${source_files})
-if(MSVC)
+if(MSVC AND NOT CMAKE_CXX_COMPILER_ID MATCHES "^Clang$")
# Turn off /Zc:preprocessor for this test because it triggers a bug in some older Windows 10 SDK headers.
set_source_files_properties(test_Stat.cpp PROPERTIES COMPILE_FLAGS /Zc:preprocessor-)
endif()