summaryrefslogtreecommitdiff
path: root/libs3.spec
diff options
context:
space:
mode:
authorBryan Ischo <bryan@ischo.com>2008-08-06 21:28:05 +0000
committerBryan Ischo <bryan@ischo.com>2008-08-06 21:28:05 +0000
commit744c19acf5d8dd7c02193bf3fafd2e6a548f43e4 (patch)
tree73df64b54066c1743b0c76c1b05569765949c869 /libs3.spec
parentc6741b1e2e3a6e7b5a46998247f7fd24046499db (diff)
downloadceph-libs3-744c19acf5d8dd7c02193bf3fafd2e6a548f43e4.tar.gz
* Made -O3 default compiler option
* Minor changes to libs3.spec * Fixed debian stuff that was polluting non-debian builds
Diffstat (limited to 'libs3.spec')
-rw-r--r--libs3.spec31
1 files changed, 15 insertions, 16 deletions
diff --git a/libs3.spec b/libs3.spec
index 7b92fe5..37980ab 100644
--- a/libs3.spec
+++ b/libs3.spec
@@ -24,30 +24,29 @@ Requires: openssl
This library provides an API for using Amazon's S3 service (see
http://s3.amazonaws.com). Its design goals are:
-- To provide a simple and straightforward API for accessing all of S3's
- functionality
-- To not require the developer using libs3 to need to know anything about:
- - HTTP
- - XML
- - SSL
- In other words, this API is meant to stand on its own, without requiring
- any implicit knowledge of how S3 services are accessed using HTTP
- protocols.
-- To be usable from multithreaded code
-- To be usable by code which wants to process multiple S3 requests
- simultaneously from a single thread
-- To be usable in the simple, straightforward way using sequentialized
- blocking requests
+ - To provide a simple and straightforward API for accessing all of S3's
+ functionality
+ - To not require the developer using libs3 to need to know anything about:
+ - HTTP
+ - XML
+ - SSL
+ In other words, this API is meant to stand on its own, without requiring
+ any implicit knowledge of how S3 services are accessed using HTTP
+ protocols.
+ - To be usable from multithreaded code
+ - To be usable by code which wants to process multiple S3 requests
+ simultaneously from a single thread
+ - To be usable in the simple, straightforward way using sequentialized
+ blocking requests
%prep
%setup -q
%build
-CFLAGS=-O3 BUILD=$RPM_BUILD_ROOT/build make exported
+BUILD=$RPM_BUILD_ROOT/build make exported
%install
BUILD=$RPM_BUILD_ROOT/build DESTDIR=$RPM_BUILD_ROOT/usr make install
-rm -rf $RPM_BUILD_ROOT/build
%clean
rm -rf $RPM_BUILD_ROOT