summaryrefslogtreecommitdiff
path: root/libs3.spec
diff options
context:
space:
mode:
authorBryan Ischo <bryan@ischo.com>2008-08-05 10:46:21 +0000
committerBryan Ischo <bryan@ischo.com>2008-08-05 10:46:21 +0000
commitf791d91f13b1105ef2c70df385120e52dae4b7c7 (patch)
tree1ba2554e39771b62c62adebc2ae063d07b43f2e0 /libs3.spec
parent43eb0fe5069da73af2074aa33a56f1a5c9de31b1 (diff)
downloadceph-libs3-f791d91f13b1105ef2c70df385120e52dae4b7c7.tar.gz
* Improve build system
* Add libs3.spec for building RPMs
Diffstat (limited to 'libs3.spec')
-rw-r--r--libs3.spec58
1 files changed, 58 insertions, 0 deletions
diff --git a/libs3.spec b/libs3.spec
new file mode 100644
index 0000000..eaeb62f
--- /dev/null
+++ b/libs3.spec
@@ -0,0 +1,58 @@
+Summary: C Library for Amazon S3 Access
+Name: libs3
+Version: trunk
+Release: 1
+License: GPL
+Group: Development/Tools
+URL: http://sourceforge.net/projects/reallibs3
+Source0: libs3-trunk.tar.gz
+Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
+Buildrequires: curl-devel
+Buildrequires: libxml2-devel
+Buildrequires: make
+Requires: curl
+Requires: libxml2
+
+%define debug_package %{nil}
+
+%description
+This library provides an API for using Amazon's S3 service (see
+http://s3.amazonaws.com). Its design goals are:
+
+- To provide a simple and straightforward API for accessing all of S3's
+ functionality
+- To not require the developer using libs3 to need to know anything about:
+ - HTTP
+ - XML
+ - SSL
+ In other words, this API is meant to stand on its own, without requiring
+ any implicit knowledge of how S3 services are accessed using HTTP
+ protocols.
+- To be usable from multithreaded code
+- To be usable by code which wants to process multiple S3 requests
+ simultaneously from a single thread
+- To be usable in the simple, straightforward way using sequentialized
+ blocking requests
+
+%prep
+%setup -q
+
+%build
+CFLAGS=-O3 BUILD=$RPM_BUILD_ROOT/build make exported
+
+%install
+BUILD=$RPM_BUILD_ROOT/build INSTALL=$RPM_BUILD_ROOT/usr make install
+rm -rf $RPM_BUILD_ROOT/build
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+/usr/bin/*
+/usr/include/*
+/usr/lib/*
+
+%changelog
+* Tue Aug 05 2008 <bryan@ischo,com> Bryan Ischo
+- Initial build.