summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb49a0b2fe1..ddbb8faf25a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,10 @@ AM_CONDITIONAL(FREEBSD, test x"$freebsd" = x"yes")
# Checks for programs.
AC_PROG_CXX
+if test "$CXX" = no || test "$CXX:$GXX" = "g++:"; then
+ AC_MSG_ERROR([no C++ compiler found])
+fi
+
#AC_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL