summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg26
1 files changed, 21 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index cd62b8dd..13afd86f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,8 +1,24 @@
+[bumpversion]
+current_version = 5.2.0
+commit = True
+tag = True
+
+[aliases]
+clean_egg_info = egg_info -RDb ''
+release = clean_egg_info sdist bdist_wheel
+
[sdist]
-formats=gztar,zip
+formats = gztar,zip
[nosetests]
-where=cherrypy
-logging-filter=cherrypy
-verbosity=2
-nocapture=True
+where = cherrypy
+logging-filter = cherrypy
+verbosity = 2
+nocapture = True
+
+[egg_info]
+tag_build = .post
+tag_date = 1
+
+[bumpversion:file:setup.py]
+