summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoman Kennke <roman@kennke.org>2006-01-18 11:31:12 +0000
committerRoman Kennke <roman@kennke.org>2006-01-18 11:31:12 +0000
commita8dd27ec123dbc987e4d57efc553554da8273035 (patch)
treeec00cdbec949fb81f256dc0e74c96722b86a0241 /configure.ac
parentbcad09931451cbbc1b156ed0a70d718e52652d18 (diff)
downloadclasspath-a8dd27ec123dbc987e4d57efc553554da8273035.tar.gz
2006-01-18 Roman Kennke <kennke@aicas.com>
* configure.ac: Added --enable-posix-layer option to enable build of the posix target layer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d4cee4ea..1e3738eb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,21 @@ AC_ARG_ENABLE([qt-peer],
[COMPILE_QT_PEER=no])
AM_CONDITIONAL(CREATE_QT_PEER_LIBRARIES, test "x${COMPILE_QT_PEER}" = xyes)
+dnl -----------------------------------------------------------
+dnl Posix layer (disabled by default)
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([posix-layer],
+ [AS_HELP_STRING(--enable-posix-layer, build the target posix layer [default=no])],
+ [case "${enableval}" in
+ yes) ENABLE_POSIX=yes ;;
+ no) ENABLE_POSIX=no ;;
+ *) ENABLE_POSIX=yes ;;
+ esac],
+ [ENABLE_POSIX=no])
+AC_SUBST(CP_NEW)
+if test "x${ENABLE_POSIX}" = xyes; then
+ AC_DEFINE(CP_NEW, 1, [defined if the posix layer should be used])
+fi
dnl -----------------------------------------------------------
dnl Sets the native libraries installation dir