summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2005-04-26 00:20:12 +0000
committerMark Wielaard <mark@klomp.org>2005-04-26 00:20:12 +0000
commitb2722d2d83271e6afc995c271862141dfa950e0a (patch)
treed6459df877b34cc32d75de88dfe6e3e26f331459 /configure.ac
parentbc5492f3da252d5c1d2fddd8fa24f693208888db (diff)
downloadclasspath-b2722d2d83271e6afc995c271862141dfa950e0a.tar.gz
* iconv.m4: New file.
* configure.ac: Use AM_ICONV. * native/jni/java-nio/Makefile.am (libjavanio_la_LIBADD): Add LTLIBICONV. * native/jni/java-nio/gnu_java_nio_charset_iconv_IconvDecoder.c: Include config.h and jcl.h, use if defined(HAVE_ICONV), add new static variables infid and outfid, add char_union. (Java_gnu_java_nio_charset_iconv_IconvDecoder_openIconv): Guard with if defined(HAVE_ICONV), use JCL_jstring_to_cstring, JCL_free_cstring and JCL_ThrowException, cache inremaining and outremaining fieldIDs. (Java_gnu_java_nio_charset_iconv_IconvDecoder_decode): Guard with if defined(HAVE_ICONV), use ICONV_CONST for iconv argument, used cached fieldIDs, use char_union. (Java_gnu_java_nio_charset_iconv_IconvDecoder_closeIconv): Guard with if defined(HAVE_ICONV). * native/jni/java-nio/gnu_java_nio_charset_iconv_IconvEncoder.c: Include config.h and jcl.h, use if defined(HAVE_ICONV), add new static variables infid and outfid, add char_union. (Java_gnu_java_nio_charset_iconv_IconvEncoder_openIconv): Guard with if defined(HAVE_ICONV), use JCL_jstring_to_cstring, JCL_free_cstring and JCL_ThrowException, cache inremaining and outremaining fieldIDs. (Java_gnu_java_nio_charset_iconv_IconvEncoder_encode): Guard with if defined(HAVE_ICONV), use ICONV_CONST for iconv argument, used cached fieldIDs, use char_union. (Java_gnu_java_nio_charset_iconv_IconvEncoder_closeIconv): Guard with if defined(HAVE_ICONV). * gnu/java/nio/charset/iconv/IconvDecoder.java (dispose): Renamed. (finalize): Renamed from dispose. * gnu/java/nio/charset/iconv/IconvEncoder.java (dispose): Renamed. (finalize): Renamed from dispose.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 95d3cd651..01475f9dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,9 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_C_CONST
+ dnl See if we HAVE_ICONV, how ICONV_CONST is set and LTLIBICONV
+ AM_ICONV
+
dnl When using gcc we want warnings, lots of warnings :-)
if test "x${GCC}" = xyes; then
dnl We want ISO C90 pedantic ansi, but with longlong (jlong) support