summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-21 21:20:17 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-21 21:20:17 +0000
commitd846cac5ac9a07e565e696ff5938800f70a04b00 (patch)
treeb279af9c445941158c3f3d5bf608a1adcb760a5c /configure.ac
parent0a724eb99cf49abfeb5f9b81fb4d39900cef2446 (diff)
downloadclasspath-d846cac5ac9a07e565e696ff5938800f70a04b00.tar.gz
2008-06-21 Andrew John Hughes <gnu_andrew@member.fsf.org>
* configure.ac: Remove --with-vm option, instead relying on AC_PROG_JAVA. Only call this if tools are enabled. * tools/gappletviewer.in, * tools/gjar.in, * tools/gjarsigner.in, * tools/gjavah.in, * tools/gjdoc.in, * tools/gkeytool.in, * tools/gnative2ascii.in, * tools/gorbd.in, * tools/grmic.in, * tools/grmid.in, * tools/grmiregistry.in, * tools/gserialver.in, * tools/gtnameserv.in: Regenerated with @JAVA@ and -classpath option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 9 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index ceb03a913..1df123bda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -300,20 +300,6 @@ AC_ARG_WITH([glibj-dir],
AC_SUBST(glibjdir)
dnl -----------------------------------------------------------
-dnl Sets the VM name for use in tool wrapper scripts
-dnl -----------------------------------------------------------
-AC_ARG_WITH([vm],
- [AS_HELP_STRING(--with-vm,sets the VM binary name [default='${prefix}/bin/jamvm'])],
- [
- VM_BINARY=${withval}
- ],
- [
- VM_BINARY='${prefix}/bin/jamvm'
- ])
-
-AC_SUBST(VM_BINARY)
-
-dnl -----------------------------------------------------------
dnl Sets the Antlr jar to use for compiling gjdoc
dnl -----------------------------------------------------------
AC_ARG_WITH([antlr-jar],
@@ -376,10 +362,6 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_CPP
-if test "x${COMPILE_GJDOC}" = xyes; then
- AC_PROG_ANTLR(2,7,1)
-fi
-
# Handle -Werror default case.
if test "$ENABLE_WERROR" = default; then
case "$host_os" in
@@ -948,6 +930,15 @@ esac;
AM_CONDITIONAL(USE_PREBUILT_GLIBJ_ZIP, test x$use_glibj_zip = xtrue)
AC_SUBST(PATH_TO_GLIBJ_ZIP)
+if test "x${TOOLSDIR}" != x; then
+ if test "x${COMPILE_WRAPPERS}" = xno; then
+ AC_PROG_JAVA
+ fi
+ if test "x${COMPILE_GJDOC}" = xyes; then
+ AC_PROG_ANTLR(2,7,1)
+ fi
+fi
+
# Check for javac if we need to build either the class library,
# the examples or the tools
if test "x${use_glibj_zip}" = xfalse || \