summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Watkins <daniel.watkins@canonical.com>2015-07-21 13:06:11 +0100
committerDaniel Watkins <daniel.watkins@canonical.com>2015-07-21 13:06:11 +0100
commit3aeec2dd6460fbdd3b8f217ad8aa231acb4bfd45 (patch)
tree3be4ff63902ce168869d4deb2b4fdbadf02ccf63 /setup.py
parent9461b1235f7278440ffb84f1e3d95b3f906e444b (diff)
downloadcloud-init-git-3aeec2dd6460fbdd3b8f217ad8aa231acb4bfd45.tar.gz
Add udev rules for Azure ephemeral disks.
And install them in the Debian packaging.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e88d9e88..5f61681b 100755
--- a/setup.py
+++ b/setup.py
@@ -84,6 +84,7 @@ INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
USR = "/usr"
ETC = "/etc"
USR_LIB_EXEC = "/usr/lib"
+LIB = "/lib"
if os.uname()[0] == 'FreeBSD':
USR = "/usr/local"
USR_LIB_EXEC = "/usr/local/lib"
@@ -167,6 +168,7 @@ else:
[f for f in glob('doc/examples/*') if is_f(f)]),
(USR + '/share/doc/cloud-init/examples/seed',
[f for f in glob('doc/examples/seed/*') if is_f(f)]),
+ (LIB + '/udev/rules.d', ['udev/66-azure-ephemeral.rules']),
]
# Use a subclass for install that handles
# adding on the right init system configuration files