summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@brickies.net>2016-08-05 15:51:34 -0400
committerScott Moser <smoser@brickies.net>2016-08-05 16:53:53 -0400
commit42bed116b411eb25ebd8368b2b4ed6c56ffd85e7 (patch)
tree60af1c21adda46878ccf9a0c6ab1b3640fa61a4a /setup.py
parent10f82bd474c5bc91b330beccd883da06b0014a99 (diff)
downloadcloud-init-git-42bed116b411eb25ebd8368b2b4ed6c56ffd85e7.tar.gz
drop modification of version during make-tarball, tools changes.
Modification of the tarball became problematic, as it meant that any tool extracting source would find the orig source tarball different. I found this unusable when trying to use 'gbp buildpackage'. Other changes here are to better support using python3 or python2 for the build. Makefile will try to call the right python version and can be told which python to use. read-version: by adding 'tiny_p' and avoiding the import of cloudinit.util, we need less dependencies to run this.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0af576a9..4abbb67e 100755
--- a/setup.py
+++ b/setup.py
@@ -116,13 +116,13 @@ def in_virtualenv():
def get_version():
- cmd = ['tools/read-version']
+ cmd = [sys.executable, 'tools/read-version']
(ver, _e) = tiny_p(cmd)
return str(ver).strip()
def read_requires():
- cmd = ['tools/read-dependencies']
+ cmd = [sys.executable, 'tools/read-dependencies']
(deps, _e) = tiny_p(cmd)
return str(deps).splitlines()