summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2016-03-18 20:40:54 -0400
committerScott Moser <smoser@ubuntu.com>2016-03-18 20:40:54 -0400
commit519c0936e3e80fc14225e500fbb61d0d12d28c35 (patch)
treec3aaf80acaf6f9208b529d84978f23de1210c071 /setup.py
parent72b56d0f59f321519f25b039937a24b0ce338295 (diff)
downloadcloud-init-git-519c0936e3e80fc14225e500fbb61d0d12d28c35.tar.gz
commit the systemd waiting mechanism
Note, still broken as cloud-init local is not going to ever touch the CI_NET_READY file (/run/cloud-init/network-config-ready). So as this is , it will actually just block for 60 seconds and go on.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0b261dfe..f86727b2 100755
--- a/setup.py
+++ b/setup.py
@@ -183,7 +183,8 @@ else:
[f for f in glob('doc/examples/*') if is_f(f)]),
(USR + '/share/doc/cloud-init/examples/seed',
[f for f in glob('doc/examples/seed/*') if is_f(f)]),
- (LIB + '/udev/rules.d', ['udev/66-azure-ephemeral.rules']),
+ (LIB + '/udev/rules.d', [f for f in glob('udev/*.rules')]),
+ (LIB + '/udev', ['udev/cloud-init-wait']),
]
# Use a subclass for install that handles
# adding on the right init system configuration files