summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGonéri Le Bouder <goneri@lebouder.net>2021-06-14 15:39:05 -0400
committerGitHub <noreply@github.com>2021-06-14 14:39:05 -0500
commit59a848c5929cbfca45d95860eb60dfebd0786c94 (patch)
treea962355634c51c6cc03b56c0dceca8c2b345a550 /setup.py
parent05b0e35026db3789c56ee9f8192d4a81067325e5 (diff)
downloadcloud-init-git-59a848c5929cbfca45d95860eb60dfebd0786c94.tar.gz
add DragonFlyBSD support (#904)
- Mostly based on FreeBSD, the main exception is that `find_devs_with_on_freebsd` does not work. - Since we cannot get the CDROM or the partition labels, `find_devs_with_on_dragonflybsd()` has a more naive approach and returns all the block devices.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cbacf48e..dcbe0843 100755
--- a/setup.py
+++ b/setup.py
@@ -156,7 +156,7 @@ USR = "usr"
ETC = "etc"
USR_LIB_EXEC = "usr/lib"
LIB = "lib"
-if os.uname()[0] == 'FreeBSD':
+if os.uname()[0] in ['FreeBSD', 'DragonFly']:
USR = "usr/local"
USR_LIB_EXEC = "usr/local/lib"
elif os.path.isfile('/etc/redhat-release'):