diff options
author | Scott Moser <smoser@ubuntu.com> | 2017-02-04 02:24:55 +0000 |
---|---|---|
committer | Scott Moser <smoser@brickies.net> | 2017-02-03 21:24:55 -0500 |
commit | 9698b0ded3d7e72f54513f248d8da41e08472f68 (patch) | |
tree | b6640cfdf3521d43970559b3fd4e36ad421e18aa /setup.py | |
parent | 9a061c1838c3e9d2ed3f3d73e30248f7a79af7da (diff) | |
download | cloud-init-git-9698b0ded3d7e72f54513f248d8da41e08472f68.tar.gz |
Add tools/ds-identify to identify datasources available.
ds-identify is run here from the generator. If ds-identify does
not see any datasources, it can completely disable cloud-init.
The big value in this is that if there is no datasource, no python
will ever be loaded, and cloud-init will be disabled.o
The default policy being added here is:
search,found=all,maybe=all,notfound=disabled
That means:
- enable (in 'datasource_list') all sources that are found.
- if none are found, enable all 'maybe'.
- if no maybe are found, then disable cloud-init.
On platforms without DMI (everything except for aarch64 and x86),
the default 'notfound' setting is 'enabled'. This is because many of
the detection mechanisms rely on dmi data, which is present only on
x86 and aarch64.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -168,7 +168,8 @@ else: (ETC + '/cloud/templates', glob('templates/*')), (ETC + '/NetworkManager/dispatcher.d/', ['tools/hook-network-manager']), (ETC + '/dhcp/dhclient-exit-hooks.d/', ['tools/hook-dhclient']), - (USR_LIB_EXEC + '/cloud-init', ['tools/uncloud-init', + (USR_LIB_EXEC + '/cloud-init', ['tools/ds-identify', + 'tools/uncloud-init', 'tools/write-ssh-key-fingerprints']), (USR + '/share/doc/cloud-init', [f for f in glob('doc/*') if is_f(f)]), (USR + '/share/doc/cloud-init/examples', |