diff options
author | Scott Moser <smoser@ubuntu.com> | 2013-03-19 09:06:31 -0400 |
---|---|---|
committer | Scott Moser <smoser@ubuntu.com> | 2013-03-19 09:06:31 -0400 |
commit | f8318f8eec9c8f1c1676ce6a5b5c2c77fa2f7cc5 (patch) | |
tree | 09a07ba4b0ef86b296597ef8876a731901b43cc6 /setup.py | |
parent | ae0f94c8f39a234d73ab8e2caf24d73439c8b5ee (diff) | |
download | cloud-init-git-f8318f8eec9c8f1c1676ce6a5b5c2c77fa2f7cc5.tar.gz |
pylint fixes
a.) appease pylint on raring, as it doesn't like subprocess
pylint: 0.26.0-1ubuntu1
This is mentioned in comments at http://www.logilab.org/ticket/46273
b.) tests/unittests/test_util.py:
the mountinfo lines are longer than 80 chars.
Just disable long lines complaints for this file.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -61,9 +61,10 @@ def tiny_p(cmd, capture=True): sp = subprocess.Popen(cmd, stdout=stdout, stderr=stderr, stdin=None) (out, err) = sp.communicate() - if sp.returncode not in [0]: + ret = sp.returncode # pylint: disable=E1101 + if ret not in [0]: raise RuntimeError("Failed running %s [rc=%s] (%s, %s)" - % (cmd, sp.returncode, out, err)) + % (cmd, ret, out, err)) return (out, err) |