summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@brickies.net>2017-08-31 20:01:57 -0600
committerChad Smith <chad.smith@canonical.com>2017-08-31 20:01:57 -0600
commitfa266bf8818a08e37cd32a603d076ba2db300124 (patch)
tree80a809e50b1a948470a016270b6e9680c56aa45b /setup.py
parent1770a1eb647d24e14732194e72210ea494986ad2 (diff)
downloadcloud-init-git-fa266bf8818a08e37cd32a603d076ba2db300124.tar.gz
upstart: do not package upstart jobs, drop ubuntu-init-switch module.
The ubuntu-init-switch module allowed the use to launch an instance that was booted with upstart and have it switch its init system to systemd and then reboot itself. It was only useful for the time period when Ubuntu was transitioning to systemd but only produced images using upstart. Also, do not run setup with --init-system=upstart. This means that by default, debian packages built with packages/bddeb will not have upstart unit files included. No other removal is done here.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5c65c7fe..7662bd8b 100755
--- a/setup.py
+++ b/setup.py
@@ -191,6 +191,8 @@ class InitsysInstallData(install):
datakeys = [k for k in INITSYS_ROOTS
if k.partition(".")[0] == system]
for k in datakeys:
+ if not INITSYS_FILES[k]:
+ continue
self.distribution.data_files.append(
(INITSYS_ROOTS[k], INITSYS_FILES[k]))
# Force that command to reinitalize (with new file list)