summaryrefslogtreecommitdiff
path: root/Auxiliary/CMakeLists.txt
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2020-03-30 23:07:37 -0400
committerEli Schwartz <eschwartz@archlinux.org>2020-03-31 12:01:40 -0400
commit2642f432ef05d083da66c0b24cd10d655f951186 (patch)
tree8c31660b905adcdc51b56e127ebb8105abe8c1a0 /Auxiliary/CMakeLists.txt
parent529d7291b40e8b4c09e3952d6992cafcee979f8c (diff)
downloadcmake-2642f432ef05d083da66c0b24cd10d655f951186.tar.gz
Aux: Install editor and bash files to more natural locations
The vim, emacs, and bash support files are not internal CMake resources and so do not belong under `CMAKE_DATA_DIR`. Move them over to proper places under the `CMAKE_XDGDATA_DIR` as we do already for cmake-gui desktop files and `cmake.m4`. Fixes: #20522
Diffstat (limited to 'Auxiliary/CMakeLists.txt')
-rw-r--r--Auxiliary/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Auxiliary/CMakeLists.txt b/Auxiliary/CMakeLists.txt
index 53cf2c518d..a833c7913f 100644
--- a/Auxiliary/CMakeLists.txt
+++ b/Auxiliary/CMakeLists.txt
@@ -1,4 +1,4 @@
-install(DIRECTORY vim/indent vim/syntax DESTINATION ${CMAKE_DATA_DIR}/editors/vim)
-install(FILES cmake-mode.el DESTINATION ${CMAKE_DATA_DIR}/editors/emacs)
+install(DIRECTORY vim/indent vim/syntax DESTINATION ${CMAKE_XDGDATA_DIR}/vim/vimfiles)
+install(FILES cmake-mode.el DESTINATION ${CMAKE_XDGDATA_DIR}/emacs/site-lisp)
install(FILES cmake.m4 DESTINATION ${CMAKE_XDGDATA_DIR}/aclocal)
add_subdirectory (bash-completion)