summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-16 16:26:39 -0400
committerBrad King <brad.king@kitware.com>2016-08-31 09:02:19 -0400
commit13b7e7587d50a52bb422852eb4d71a93eb8f18a6 (patch)
treedfcaef4dc5f2aef27c8473e6f8f4f1b15e4d6e60 /CMakeLists.txt
parentd96416fe482e17bc9f5a741d71d4a51a9b44f65e (diff)
downloadcmake-13b7e7587d50a52bb422852eb4d71a93eb8f18a6.tar.gz
libuv: Build the library within CMake
Take logic from upstream `Makefile.am` and `configure.ac` to build libuv sources. Update `uv.h` to include KWSys Large File Support configuration so that consistent stream libraries are used (on AIX with XL). Add a `cm_uv.h` header to include the CMake-provided copy of the `uv.h` header from CMake sources.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3aef619732..958beb633f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -464,6 +464,19 @@ macro (CMAKE_BUILD_UTILITIES)
endif()
#---------------------------------------------------------------------
+ # Build libuv library.
+ if(NOT DEFINED CMAKE_USE_LIBUV)
+ set(CMAKE_USE_LIBUV 1)
+ endif()
+ if(CMAKE_USE_LIBUV)
+ set(CMAKE_LIBUV_LIBRARIES cmlibuv)
+ add_subdirectory(Utilities/cmlibuv)
+ CMAKE_SET_TARGET_FOLDER(cmlibuv "Utilities/3rdParty")
+ else()
+ set(CMAKE_LIBUV_LIBRARIES)
+ endif()
+
+ #---------------------------------------------------------------------
# Build XMLRPC library for CMake and CTest.
if(CTEST_USE_XMLRPC)
find_package(XMLRPC QUIET REQUIRED libwww-client)