summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChuck Atkins <chuck.atkins@kitware.com>2019-03-12 17:14:02 +0000
committerChuck Atkins <chuck.atkins@kitware.com>2019-03-12 17:14:02 +0000
commit2c280acdf836b661cdfb2bdf3a3b5f1fda15a424 (patch)
tree9daca44b1700c6c381e398cc06b29650f628f49e /CMakeLists.txt
parent06a59f1bda3ee5e1990f664dc3e2dd6d1acba81c (diff)
downloadcmake-2c280acdf836b661cdfb2bdf3a3b5f1fda15a424.tar.gz
JsonCpp: Ignore deprecation warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69e3064466..abf62bf6a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -538,6 +538,10 @@ macro (CMAKE_BUILD_UTILITIES)
message(FATAL_ERROR
"CMAKE_USE_SYSTEM_JSONCPP is ON but a JsonCpp is not found!")
endif()
+ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+ set_property(TARGET JsonCpp::JsonCpp APPEND PROPERTY
+ INTERFACE_COMPILE_OPTIONS -Wno-deprecated-declarations)
+ endif()
set(CMAKE_JSONCPP_LIBRARIES JsonCpp::JsonCpp)
else()
set(CMAKE_JSONCPP_LIBRARIES cmjsoncpp)