summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-02-27 09:28:24 -0500
committerBrad King <brad.king@kitware.com>2023-02-27 09:30:04 -0500
commit2fc3b0f47604caad605cd4672b159c98355883e0 (patch)
treefe929d5c31fc1ba37ac6564b2404042eacfe19c9 /CMakeLists.txt
parent38c0205cdde343b44442bc4477519fb23ce5ed49 (diff)
downloadcmake-2fc3b0f47604caad605cd4672b159c98355883e0.tar.gz
Tests: Drop use of legacy "Dart" module
Use the CTest module directly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d11b4cd493..0ce42fb3aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -241,10 +241,6 @@ macro(CMAKE_SETUP_TESTING)
configure_file(Tests/.NoDartCoverage Tests/.NoDartCoverage)
configure_file(Tests/.NoDartCoverage Modules/.NoDartCoverage)
configure_file(CTestCustom.cmake.in CTestCustom.cmake @ONLY)
- if(BUILD_TESTING AND DART_ROOT)
- configure_file(CMakeLogo.gif Testing/HTML/TestingResults/Icons/Logo.gif COPYONLY)
- endif()
- mark_as_advanced(DART_ROOT)
endmacro()
@@ -361,9 +357,7 @@ endif()
#-----------------------------------------------------------------------
include(Source/CMakeVersion.cmake)
-# Include the standard Dart testing module
-enable_testing()
-include(${CMAKE_ROOT}/Modules/Dart.cmake)
+include(CTest)
# Set up test-time configuration.
set_directory_properties(PROPERTIES