summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-03-30 11:41:22 -0400
committerBrad King <brad.king@kitware.com>2020-03-30 11:43:08 -0400
commit39e5a4da220c1ddcd73d74d26ed55a7418add215 (patch)
treefa647d47de0866395ea56efe938fa08f7fd4efe2 /CMakeLists.txt
parentb7d8c91822101ff9de07075e9b1f02e18c2725da (diff)
downloadcmake-39e5a4da220c1ddcd73d74d26ed55a7418add215.tar.gz
AIX: Install ExportImportList script with execute permission
This script was added by commit 0f150b69d3 (AIX: Explicitly compute shared object exports for both XL and GNU, 2019-07-11, v3.16.0-rc1~418^2~2) but does not have a `.sh` extension so our existing install rules neglect to give it execute permission. Our test suite works on AIX in the build tree but the script is broken without execute permission on installation. Fixes: #20520
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da99a6ee8d..3c2ea8b022 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -841,6 +841,10 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
PATTERN "*.sh*" PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
GROUP_READ GROUP_EXECUTE
WORLD_READ WORLD_EXECUTE
+ PATTERN "ExportImportList"
+ PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
+ GROUP_READ GROUP_EXECUTE
+ WORLD_READ WORLD_EXECUTE
REGEX "Help/(dev|guide)($|/)" EXCLUDE
)