summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-28 11:24:26 -0500
committerBrad King <brad.king@kitware.com>2017-11-28 11:24:26 -0500
commit4ff89fb6084d84aabe2e64aeccad03794af65a8a (patch)
tree0982bae88c784b984465112c287ddc48a72dbe42 /CMakeLists.txt
parent6e613ff399166c59e881331027e65c601feab807 (diff)
downloadcmake-4ff89fb6084d84aabe2e64aeccad03794af65a8a.tar.gz
AIX: Add -pthread flag to enable std::thread with GCC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fafe536e22..ebeca225ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,11 @@
# file Copyright.txt or https://cmake.org/licensing for details.
cmake_minimum_required(VERSION 3.1 FATAL_ERROR)
+set(CMAKE_USER_MAKE_RULES_OVERRIDE_C ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideC.cmake)
+set(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideCXX.cmake)
project(CMake)
+unset(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX)
+unset(CMAKE_USER_MAKE_RULES_OVERRIDE_C)
# Make sure we can find internal find_package modules only used for
# building CMake and not for shipping externally