summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThePrez <jgorzinski@gmail.com>2020-03-05 14:41:16 -0500
committerBrad King <brad.king@kitware.com>2020-03-05 15:07:46 -0500
commit917db8163d645eb1dfe61ee9d74eb373fe0b4b2f (patch)
treef3a106c9eb6f94a207a726a60fc5f7ba09105d95 /CMakeLists.txt
parentb7d8c91822101ff9de07075e9b1f02e18c2725da (diff)
downloadcmake-917db8163d645eb1dfe61ee9d74eb373fe0b4b2f.tar.gz
cmstd: Remove -isystem option for IBM i (OS400)
Much like AIX, IBM i (OS identifier "OS400") implicitly adds `extern "C"` around system header files included with the `-isystem` option. Update the condition added by commit c688b401d3 (cmstd: Modernize CMake system headers, 2019-08-04, v3.16.0-rc1~81^2~1) to treat `IBM i` as we do AIX.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da99a6ee8d..ee736ddb0c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,7 +368,7 @@ macro (CMAKE_BUILD_UTILITIES)
# Setup third-party libraries.
# Everything in the tree should be able to include files from the
# Utilities directory.
- if (CMAKE_SYSTEM_NAME STREQUAL "AIX" AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ if ((CMAKE_SYSTEM_NAME STREQUAL "AIX" OR CMAKE_SYSTEM_NAME STREQUAL "OS400") AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
# using -isystem option generate error "template with C linkage"
include_directories("${CMake_SOURCE_DIR}/Utilities/std")
else()