summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan Ogilvie <mr.exodia.tpodt@gmail.com>2022-01-14 17:31:28 +0100
committerBrad King <brad.king@kitware.com>2022-01-18 16:35:39 -0500
commit9278c6e01a1ce1b93b51522d1bee50eceaf86c3c (patch)
tree8e4c28b06b67f63b06d74b7903f5144cad94f348 /CMakeLists.txt
parentb97c12babbc87324b8005cf7e81640e1f3c0ecf6 (diff)
downloadcmake-9278c6e01a1ce1b93b51522d1bee50eceaf86c3c.tar.gz
ccmake: Add Windows support using PDCurses
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f7a510834..428b040f41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -674,10 +674,10 @@ macro (CMAKE_BUILD_UTILITIES)
if (UNIX)
include(${CMake_SOURCE_DIR}/Source/Checks/Curses.cmake)
set(BUILD_CursesDialog_DEFAULT "${CMakeCheckCurses_COMPILED}")
- option(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" "${BUILD_CursesDialog_DEFAULT}")
- else()
- set(BUILD_CursesDialog 0)
+ elseif(WIN32)
+ set(BUILD_CursesDialog_DEFAULT "OFF")
endif()
+ option(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" "${BUILD_CursesDialog_DEFAULT}")
endif ()
if(BUILD_CursesDialog)
if(UNIX)
@@ -690,6 +690,13 @@ macro (CMAKE_BUILD_UTILITIES)
)
set(BUILD_CursesDialog 0)
endif()
+ elseif(WIN32)
+ # FIXME: Add support for system-provided pdcurses.
+ add_subdirectory(Utilities/cmpdcurses)
+ set(CURSES_LIBRARY cmpdcurses)
+ set(CURSES_INCLUDE_PATH "") # cmpdcurses has usage requirements
+ set(CMAKE_USE_SYSTEM_FORM 0)
+ set(HAVE_CURSES_USE_DEFAULT_COLORS 1)
endif()
endif()
if(BUILD_CursesDialog)