summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-02-22 12:57:29 -0500
committerBrad King <brad.king@kitware.com>2018-02-22 12:59:20 -0500
commit94eee5e683b80e0ffd8e0c4fd3a45b03f0f37b18 (patch)
tree3deadfab4529a0be8cad86aad033ea620eb0d487 /CMakeLists.txt
parent9c1efb614dee294cb3a1077e8a232573f309c605 (diff)
downloadcmake-94eee5e683b80e0ffd8e0c4fd3a45b03f0f37b18.tar.gz
CMakeLib: Link to system thread libraries to support std::thread
Some environments require linking to thread libraries for `std::thread`. Express this direct dependency of CMakeLib explicitly. Previously this was done indirectly through our bundled libuv, but that does not work when using a system libuv. Fixes: #17757
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4d2a9a0a2..66239595ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -310,6 +310,8 @@ endmacro()
# Simply to improve readability of the main script.
#-----------------------------------------------------------------------
macro (CMAKE_BUILD_UTILITIES)
+ find_package(Threads)
+
#---------------------------------------------------------------------
# Create the kwsys library for CMake.
set(KWSYS_NAMESPACE cmsys)