summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2022-12-07 10:25:31 -0500
committerKyle Edwards <kyle.edwards@kitware.com>2022-12-08 09:42:27 -0500
commitb2b1faa40323efa1d686f98585be77475e774657 (patch)
treece607ab28073e47c953c6a5334766f11faab2bf7 /CMakeLists.txt
parent986fce1fa7c1ec53871eeda5bcabdedab5427bd1 (diff)
downloadcmake-b2b1faa40323efa1d686f98585be77475e774657.tar.gz
CMake: add option to export clang-tidy fixes to a directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a61113a872..0485b041a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,6 +277,15 @@ if(CMake_RUN_CLANG_TIDY)
set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS "${CMake_CLANG_TIDY_MODULE}")
endif()
+ set(CMake_CLANG_TIDY_EXPORT_FIXES_DIR "" CACHE PATH "Directory to put clang-tidy fix files in.")
+ mark_as_advanced(CMake_CLANG_TIDY_EXPORT_FIXES_DIR)
+ if(CMake_CLANG_TIDY_EXPORT_FIXES_DIR)
+ if(NOT IS_ABSOLUTE "${CMake_CLANG_TIDY_EXPORT_FIXES_DIR}")
+ message(FATAL_ERROR "CMake_CLANG_TIDY_EXPORT_FIXES_DIR must be an absolute path!")
+ endif()
+ set(CMAKE_CXX_CLANG_TIDY_EXPORT_FIXES_DIR "${CMake_CLANG_TIDY_EXPORT_FIXES_DIR}")
+ endif()
+
# Create a preprocessor definition that depends on .clang-tidy content so
# the compile command will change when .clang-tidy changes. This ensures
# that a subsequent build re-runs clang-tidy on all sources even if they