summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-05-20 11:35:16 -0400
committerBrad King <brad.king@kitware.com>2015-05-20 11:35:32 -0400
commitb5906ed03ab98b7749522d4f8211e9bcc55596c4 (patch)
tree525bee36f0a7967b8004f420cda698249cc5e7c0 /CMakeLists.txt
parentd7923b82ade9f84d0fc4c6d44b9719f2f7c0e9af (diff)
downloadcmake-b5906ed03ab98b7749522d4f8211e9bcc55596c4.tar.gz
Check for std::unordered_map only if we are building CMake
When CMake_TEST_EXTERNAL_CMAKE is set then we are not actually building CMake so we do not need this check.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a75666216..1b91ab893e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,9 @@ if(NOT DEFINED CMAKE_CXX_STANDARD AND NOT CMake_NO_CXX_STANDARD)
set(CMAKE_CXX_STANDARD 11)
endif()
endif()
-include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx11_unordered_map.cmake)
+if(NOT CMake_TEST_EXTERNAL_CMAKE)
+ include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx11_unordered_map.cmake)
+endif()
# option to set the internal encoding of CMake to UTF-8
option(CMAKE_ENCODING_UTF8 "Use UTF-8 encoding internally." ON)