summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Berge <eric.berge@quantum.com>2016-12-21 15:34:11 -0600
committerEric Berge <eric.berge@quantum.com>2016-12-21 15:34:11 -0600
commitba8bb32162ae7bc42c4a3a521a4e4b98274d9d8e (patch)
treeb9694a0ebfbd94173d3a7aea2fad5e3d8294df48 /CMakeLists.txt
parent4918cd8c98938ab245d7fea74ba6e20f3ec8ef8b (diff)
downloadcmake-ba8bb32162ae7bc42c4a3a521a4e4b98274d9d8e.tar.gz
Disable libuv on Solaris 10
Two issues need to be resolved to add Solaris 10 libuv support: 1. libuv needs to provide alternative functionality for systems that do not support mkdtemp() 2. cmake should set SUNOS_NO_IFADDRS for Solaris 10 builds (but not Solaris 11)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aa8010b97..bec81a38cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -510,6 +510,9 @@ int main(void) { return 0; }
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
# Disable until it can be ported.
set(CMAKE_USE_LIBUV 0)
+ elseif(CMAKE_SYSTEM STREQUAL "SunOS-5.10")
+ # Disable until it can be ported.
+ set(CMAKE_USE_LIBUV 0)
endif()
endif()
if(CMAKE_USE_LIBUV)