summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-05-26 17:42:03 -0400
committerBrad King <brad.king@kitware.com>2020-05-27 14:09:20 -0400
commitbc681fc3724857ee2def37e8fadd47e2916a7e55 (patch)
treef01bbdbd42fd794d81a19dba0fc5ea6815af0c7f /CMakeLists.txt
parent7a40d87036afa10b9ebcefa3ec971072eb456e71 (diff)
downloadcmake-bc681fc3724857ee2def37e8fadd47e2916a7e55.tar.gz
Hard-code some try_compile results for third-party libraries
Our bundled third-party libraries perform many `try_compile` checks for compatibility with their upstream build systems. For many of the checks we already know the result for compilers we support for building CMake itself, especially on Windows. Hard-code known results to avoid running the checks.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35531c6dca..15dbcd3306 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -337,6 +337,9 @@ endmacro()
macro (CMAKE_BUILD_UTILITIES)
find_package(Threads)
+ # Suppress unnecessary checks in third-party code.
+ include(Utilities/cmThirdPartyChecks.cmake)
+
#---------------------------------------------------------------------
# Create the kwsys library for CMake.
set(KWSYS_NAMESPACE cmsys)