summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Würth <wuerth.peter@freenet.de>2022-01-27 15:20:15 +0100
committerBrad King <brad.king@kitware.com>2022-01-28 06:23:57 -0500
commitc050d6a01e14500903619589e69a973f1215d109 (patch)
treed78eb4dec319610788d4518d2fe3225e889b9b7c /CMakeLists.txt
parent44939f01e761568ab9fe511d2ddf81a48c7c54b9 (diff)
downloadcmake-c050d6a01e14500903619589e69a973f1215d109.tar.gz
string(TIMESTAMP): add %f specifier for microseconds
The %f specified extends the string(TIMESTAMP) and file(TIMESTAMP) commands to output the timestamp with a microsecond resolution. This convention is offered by python's datetime module. Before, the precision was limited to seconds. The implementation is done by extending existing cmTimestamp methods with a `microseconds` parameter. This parameter is optional in order to be backwards compatible. The timestamps are now received in a cross-platform manner using libuv, since the standard C functions like time() don't allow for sub-second precision. This requires libuv 1.28 or higher. We already require higher than that on Windows, so update the required version for other platforms. Implements: #19335
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 428b040f41..b2ab30e152 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -655,7 +655,7 @@ macro (CMAKE_BUILD_UTILITIES)
if(WIN32)
find_package(LibUV 1.38.0)
else()
- find_package(LibUV 1.10.0)
+ find_package(LibUV 1.28.0)
endif()
if(NOT LIBUV_FOUND)
message(FATAL_ERROR