summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-08-19 11:41:32 -0400
committerBrad King <brad.king@kitware.com>2019-08-19 11:41:32 -0400
commitd56a4b16ca6f09d099c2ec832b11708f9b4b9819 (patch)
tree5500f4b8124bfc6907b4ff0f9910d48f903fcd80 /CMakeLists.txt
parent1958c78fe1d600e1d1d4cde480907ac6fcad4a1e (diff)
downloadcmake-d56a4b16ca6f09d099c2ec832b11708f9b4b9819.tar.gz
Help: Restore installation of top-level index
We removed installation of `Help/index.rst` in commit d2fde94809 (Help: Add infrastructure for guide-level documentation, 2019-05-30), but the file is required for `--help-full` to work. Restore installation of the file and update it to avoid referencing the `Help/guide` directory in its toctree during processing by `cmRST`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75ac8bfac5..5e3d39de8c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -813,7 +813,7 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
PATTERN "*.sh*" PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
GROUP_READ GROUP_EXECUTE
WORLD_READ WORLD_EXECUTE
- REGEX "Help/(dev|guide|index.rst)($|/)" EXCLUDE
+ REGEX "Help/(dev|guide)($|/)" EXCLUDE
)
# Install auxiliary files integrating with other tools.